HSRP Tutorial

CORE Router:

hostname R1

interface FastEthernet1/0
ip address 192.168.1.253 255.255.255.0
standby 5 ip 192.168.1.254 255.255.255.0
standby 5 timers 5 15
standby 5 priority 150
standby 5 preempt

BACKUP Router:

hostname R2
interface FastEthernet1/0
ip address 192.168.1.252 255.255.255.0
standby 5 timers 5 15
standby 5 priority 140
standby 5 preempt
standby 5 ip 192.168.1.254 255.255.255.0

Show commands :

Show standby

FastEthernet2/0 – Group 1
Local state is Standby, priority 100, may preempt

Hellotime 5 sec, holdtime 15 sec

Next hello sent in 0.974

Virtual IP address is 208.229.144.1 configured

Active router is 208.229.144.5, priority 110 expires in 13.396

Standby router is local

4 state changes, last state change 5d03h

IP redundancy name is “hsrp-Fa2/0.1-1″ (default)

Friday August 11, 2006 at 4:45 IBS has a core router fail down hard. Our monitoring system work flawlessly sending pages to noc personnel alerting of the failure. The best part was Impact only received 4 calls from T-1 customers directly connected to the 7200 VXR router that failed. I was the first to respond to the outage. I could not physically see the router lights from my position in the noc but I could see the lights on the T-1 CSU/DSU all off, not good. So I stood up in my chair to see the lights on the router, zero – none total lights out. Wow, very weird the router has redundant power supplies connected to separate electrical circuits. First thought power so I glanced to
some other equipment attached to the power, fine. Ok reboot the router, I walked behind the rack rows to the router and cycled the power on each of the power supplies, lights for only one second, wait a minute I smell burning electronics.

I grabbed my camera phone quick and snapped a picture (I know those things were good for something) of the connections, noted the DS3 connections and removed all the connections, and pulled the router. Ok I know the router is having problems so I start at the first logical place the NPE (Network Processing Engine), still nothing. Ok lets use what the man upstairs gave me, pulled all cards, and physically inspect all cards, perfect. Now take a look an the 7204
chassis looks good but there is a odd smell from the fan assembly. Ok found it the fan chassis burned up and caused the failure. I would like to take a moment and say that every Cisco guru I have spoke to says the chassis malfunction is unheard of. Dam why can’t I win the lottery instead!!!

The Fix

Ok lets role. We have a route server that I can use to get the T-1 customers up and running until we figure out what to do with this mess. So I moved all the cards to the new chassis placed the router in the rack powered up the unit,
watched the router POST and start. Boom back up and running.

Down time for the T-1 customers 12 minutes (on a Friday at 5 pm, Quitting Time)

The Point

Why didn’t my network crumble and shutdown, Answer HSRP. HSRP is Cisco’s Hot Standby Routing Protocol. The protocol shares a Virtual IP address on a Virtual Mac Address between 2 or more routers (2 in this example).

The Configuration

IBS routes out a main router we call “the core” and we have a backup router for this type of scenario. HSRP is simple to configure you need 2 routers and 3 free IP addresses. Here is my configuration of the Core

CORE Router:

interface FastEthernet0/0

ip address 208.229.144.5 255.255.255.0

standby 1 ip 208.229.144.1

standby 1 timers 5 15

standby 1 priority 110 (This sets the router to obtain the active router status
once the router is online )

standby 1 preempt (look for a better

BACKUP Router:

interface FastEthernet2/0

ip address 208.229.144.8 255.255.255.0

standby timers 5 15

standby preempt

standby 1 ip 208.229.144.1

Show commands :

Show standby :

FastEthernet2/0 – Group 1
Local state is Standby, priority 100, may preempt

Hellotime 5 sec, holdtime 15 sec

Next hello sent in 0.974

Virtual IP address is 208.229.144.1 configured

Active router is 208.229.144.5, priority 110 expires in 13.396

Standby router is local

4 state changes, last state change 5d03h

IP redundancy name is “hsrp-Fa2/0.1-1″ (default)

Cheers

Jim G

IBS Network Team